Mathematica中文论坛-非官方

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 1155|回复: 2

豆粑粑 ubuntu 16.04 theano 0.8

[复制链接]

442

主题

491

帖子

2411

积分

金牌会员

Rank: 6Rank: 6

积分
2411
发表于 2020-12-14 11:54:55 | 显示全部楼层 |阅读模式
本帖最后由 meatball1982 于 2020-12-14 11:57 编辑

重复一个文献,安装theano 在GPU端实现训练。
之前,已经在服务器上配置好了。后来,服务器挂了一次,对,服务器挂了一次,完全用不了。需要重新配置。真是让人有自杀的冲动。

文章给的是python2.7
我安装的是基于python3.5,除了print那部分是有些个差异,其它的,暂时看,没什么问题。
为了不影响 其它人, 我选择的是用conda 构建一个环境来实现。

具体的,env_Theano.yml

  1. name: th_py
  2. dependencies:
  3. - python=3.5
  4. - cudatoolkit=8.0
  5. - cudnn=5.0
  6. - h5py
  7. - numpy
  8. - mkl-service
  9. - scikit-learn=0.17
  10. - nose
  11. - theano=0.8.2
复制代码




找的是服务器中,唯一的一个ubuntu16.04的节点。
theano=0.8.2   -> cudnn V4, V5
注意,不是V5.1

cudnn-> cudatoolkit 8.0
ubuntu16.04能支持cudatoolkit 8.0

这其中, 还要注意的是
scikit-learn 不能高于0.18
通过conda env create -f env_Tehano.yml
安装 环境 。
通过
conda activate th_py
来激活环境,相当于是说,之后的工作,就在这个环境 中实现。
lasagne不能和0.1版本。
尝试在git 上安装 。

pip install -------
pip install -------

就是git 上,安装的那两行。



除了lasagne 还要pip install nolearn



编辑~/.theanorc


  1. [global]
  2. #openmp=False
  3. device =gpu
  4. #device =gpu1,device=gpu3
  5. floatX = float32
  6. allow_input_downcast=True
  7. [lib]
  8. cnmem = 0.5
  9. [blas]
  10. ldflags= -lopenblas
  11. [nvcc]
  12. flags=-D_FORCE_INLINES

  13. fastmath = True
  14. [cuda]
  15. #root=/opt/cuda-8.0
  16. #root=/usr/local/cuda-10.1
  17. root=/usr/local/cuda-8.0

  18. [dnn]
  19. enabled=True
  20. #enabled=False
  21. #library_path=/usr/cuda-8.0/lib64
  22. #include_path=/usr/cuda-8.0/include
  23. #library_path=/usr/local/cuda-10.1/lib64
  24. #include_path=/usr/local/cuda-10.1/include
  25. library_path=/root/anaconda3/envs/th_py/lib
  26. include_path=/root/anaconda3/envs/th_py/include
复制代码




python
import theano
告诉你,我用了啥显卡,用了cudnn是多少。




复制代码



回复

使用道具 举报

442

主题

491

帖子

2411

积分

金牌会员

Rank: 6Rank: 6

积分
2411
 楼主| 发表于 2020-12-22 09:53:52 | 显示全部楼层
  1. linux ubuntu theano RuntimeError: Mixed dnn version. The header is version
复制代码


如果遇到 这个问题。
找到上述报错中提到的: /home/user1/.local/lib/python3.6/site-packages/theano/gpuarray 中的 dnn.py,打开

    将v = f()
    改成
    v = (5005, 5005)

5005是你机器上安装的cudnn版本
回复 支持 反对

使用道具 举报

442

主题

491

帖子

2411

积分

金牌会员

Rank: 6Rank: 6

积分
2411
 楼主| 发表于 2020-12-22 21:44:54 | 显示全部楼层
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|Mathematica中文论坛-非官方 ( 辽ICP备16001491号-1

GMT+8, 2021-1-24 20:59 , Processed in 0.121324 second(s), 23 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表